WordPress Pluggable Hatasının Çözümü

1 sene önce Smile tarafından yazıldı ve hakkında hiç yorum yapılmadı.

WordPress kullanmaktan memnun olsak da bazen hatalarla da karşılaşmıyor değiliz. Bugün başka bir WordPress sitemde karşılaştığım hatanın çözümünü paylaşmak istedim. Hata tam olarak şuydu:

“Warning: Cannot modify header information – headers already sent by (output started at /home/xxx/public_html/wp-content/themes/temanız/includes/theme-functions.php:1) in /home/xxx/public_html/wp-includes/pluggable.php on line 866¨

İnternette yapılan küçük bir araştırma sonucu çözüm yolunu buldum ve başkalarına da faydalı olsun istedim. Birkaç çözüm yolu öneriliyor.

İnternette ararken bulduğum ilk çözümde bu hatanın wp-config.php dosyasından kaynaklandığından bahsediliyordu. Çözüm ise wp-config.php dosyanın notepad ile açılıp UTF8 veya ANSI kodlamasıyla kaydetmemizi söylüyordu. Fakat ben bunu denedim bu işe yaramadı.

Başka bir çözüm yolu aramaya koyuldum. Diğer bulduğum bilgi ise işime yaramıştı. Bu çözüm yolunda wp-includes/pluggable.php dosyasını notepad ile açarak en başına

<?php ob_start(); ?>

kodunu ekleyerek sorundan kurtuluyoruz.

İlk çözüm yolunu da deneyebilirsiniz ancak ikinci çözüm benim sorunumu çözdüğü için ilk olarak onu denemenizi öneririm. Yazımız umarım faydalı olmuştur. Kullandığımız bütün sistem ve programlarda sorunsuz günler dileğiyle…

 

Benzer Yazılar

Yorumlar

istanbul escort-